Forum
J! JAPAN TOP
ようこそ, ゲスト
ユーザ名: パスワード: 自動ログイン

トピック: Apache mod_rewrite利用

Apache mod_rewrite利用 10 年 9 ヶ月 ago #309

  • yoshiro
  • yoshiro さんのアバター
  • Offline
  • Fresh Boarder
  • 投稿数: 7
  • カルマ: 0
あけましておめでとうございます。
新年早々お世話になります。

LinuxのApacheのwebサーバです。
mod_rewriteは、デフォルト有効になっていました。
システム - SEF デフォルトで有効でした。
Joomla!のhtaccess.txtを.htaccessに変えました。

以上の設定で

基本設定のサイト設定のSEO設定のApache mod_rewrite利用を[はい]すると
トップページ以外のページがブラウザのHTTP404errorになってしまいます。

適切な設定方法・解決策を教えて下さい。:(
ゲストの書き込みは許可されていません。

Re:Apache mod_rewrite利用 10 年 9 ヶ月 ago #312

  • siraisi
  • siraisi さんのアバター
  • Offline
  • Platinum Boarder
  • 投稿数: 462
  • 感謝を受け取りました 47
  • カルマ: 32
問題はなさそうですが。

自宅サーバ ということなので

.htaccessの参考ページです。
http://httpd.apache.org/docs/2.2/ja/howto/htaccess.html

AllowOverride None
   ↓
AllowOverride All

など、もう一度確認してみてはいかがでしょう。

間違っていたらすみません。
mail: このメールアドレスはスパムボットから保護されています。閲覧するにはJavaScriptを有効にする必要があります。
ゲストの書き込みは許可されていません。

Re:Apache mod_rewrite利用 10 年 9 ヶ月 ago #313

  • saki
  • saki さんのアバター
  • Offline
  • Fresh Boarder
  • 有限会社パーツ代表 コミック検索「なびコミ」を運営。
  • 投稿数: 1
  • カルマ: 0
私の場合は、さくらインターネットでしたが、同じような現象が発生しました。

そのときは、.htaccess(htaccess.txt)の23行目を#でコメント化
#Options +FollowSymLinks

こうする事で対応できました:)

あと、
28行目のRewriteEngine Onを有効にしておく必要がありましたよ。
ゲストの書き込みは許可されていません。

Re:Apache mod_rewrite利用 10 年 9 ヶ月 ago #315

  • yoshiro
  • yoshiro さんのアバター
  • Offline
  • Fresh Boarder
  • 投稿数: 7
  • カルマ: 0
siraisiさん sakiさん 回答ありがとうございます。

問題解決しました。

サーバ側の設定の問題でした
まさにsiraisiさんの指摘したとおりでした。

AllowOverride None
   ↓
AllowOverride All

セキュリティーを考慮のため
自らAllowOverride None設定していたことを忘れていました。

ありがとうございました。
ゲストの書き込みは許可されていません。