Forum
J! JAPAN TOP
ようこそ, ゲスト
ユーザ名: パスワード: 自動ログイン

トピック: PHP変更について

PHP変更について 5 年 7 ヶ月 ago #4753

  • hanji009
  • hanji009 さんのアバター
  • Offline
  • Platinum Boarder
  • 投稿数: 466
  • 感謝を受け取りました 18
  • カルマ: 10
吉田@Goyat LLCです。

Rokboxについては、使っていないので詳細は分かりません。フォーラムで聞くのがベストです。
www.rockettheme.com/forum/free-joomla-stuff

Joomfishのエラーも使っていないので分かりません。これもJoomfishのフォーラムで聞くのがベストです。
www.joomfish.net/forum/index.php

これでも難しいならば、サーバーの引っ越しです。
それでもダメならば、Joomla 2.5で再構築です。
ゲストの書き込みは許可されていません。

PHP変更について 5 年 7 ヶ月 ago #4754

  • Eileen
  • Eileen さんのアバター
  • Offline
  • Senior Boarder
  • 投稿数: 57
  • カルマ: 0
吉田様、

お世話になっております。細かい部分までご教示ありがとうございました。
メンバーでないため、フォーラムで質問できるかどうかわかりませんが、もう少し調べてみます。
Joomfishについても、不具合が直らない場合はフォーラムで聞いてみます。
どちらにしても、吉田様の仰るように将来的には再構築が必要になると思うので、今から検討してみます。
いろいろアドバイスいただきありがとうございました。
ゲストの書き込みは許可されていません。

PHP変更について 5 年 7 ヶ月 ago #4755

  • hanji009
  • hanji009 さんのアバター
  • Offline
  • Platinum Boarder
  • 投稿数: 466
  • 感謝を受け取りました 18
  • カルマ: 10
吉田@Goyat LLCです。

Joomla 2.5へのマイグレーションという助言をしましたが、もし、急がないならばJoomla 3.3が4月下旬にリリースされますのでJoomla 3で再構築をされたほうが良いかもしれません。

Joomla 2.5は枯れたシステムで安心です。ただ、そのライフが2014年12月で終わります。そうするとまたJoomla 3にマイグレーションです。Joomla 2.5から3へのマイグレーションは、Joomla 1.5から2.5や3へのマイグレーションと比べ非常に簡単になっています(テンプレートやエクステンションがそれぞれのバージョンに対応している場合のみ)。

その意味合いでJoomla 3.3がリリースされて落ち着いた時に検討されてはどうでしょうか。年末には、Joomla 3.4がリリースされる予定です。Joomla 3.3も3.4もLong Term Supportは2年間です。
ゲストの書き込みは許可されていません。

PHP変更について 5 年 7 ヶ月 ago #4756

  • siraisi
  • siraisi さんのアバター
  • Offline
  • Platinum Boarder
  • 投稿数: 462
  • 感謝を受け取りました 47
  • カルマ: 32
Eileen 様

Joomfishなどの対応が難しかったようですね。

Joomfish などのサードパーティ製のコンポーネントやモジュールは、Joomla!やPHPのバージョンアップに対しての対応が遅くなる場合があります。
そうすると、Joomla!のアップグレードも躊躇しなければなりません。

サードパーティー製のコンポーネント、モジュールなどを利用する場合は、それの開発状況(将来的にどうなのか?)、フォーラムは活発なのか?などを勘案して利用するべきです。


エラー文の件ですが、これはPHP3にした場合、JoomfishなどのPHPプログラムに「推奨されない構文や因数が含まれています」という注意勧告みたいなものです。だから今の内に修正できれば修正してくださいという事です。将来PHP6になった場合は完全に動作しません。

よって、エラー文を無視すればよろしいかと思います。

.htaccess に下記を追加してみてください。
php_flag display_errors off

暫くJoomla!1.5で稼働しておいて、吉田様のご指摘のようにJoomla3.3に移行準備をされてはいかがでしょうか。
mail: このメールアドレスはスパムボットから保護されています。閲覧するにはJavaScriptを有効にする必要があります。
ゲストの書き込みは許可されていません。

PHP変更について 5 年 7 ヶ月 ago #4757

  • Eileen
  • Eileen さんのアバター
  • Offline
  • Senior Boarder
  • 投稿数: 57
  • カルマ: 0
吉田様、

Joomla!についてのバージョン情報ありがとうございました。
PHP5.2のサポートは6月に終了しますが、5.3はまだすぐに終了はしないと思いますので、吉田様がおっしゃるように、Joomla 3.3がリリースされて落ち着いた時に検討するのが良さそうですね。
とりあえず、Joom!Fishの不具合の件をサポート掲示板に投稿しました。すぐに反映されないようなので、回答を待ってみます。
いろいろありがとうございました。大変勉強になりました。
ゲストの書き込みは許可されていません。

PHP変更について 5 年 7 ヶ月 ago #4758

  • Eileen
  • Eileen さんのアバター
  • Offline
  • Senior Boarder
  • 投稿数: 57
  • カルマ: 0
siraisi様、

ご返信ありがとうございました。
Joomla!は3年前に構築したのですが、CMSというものが全く初めてで、PHPやエクステンション、Joomla!本体のバージョンのことなどは全く気にしておりませんでした。
そのため、今になって急な対応になってしまったわけですが、今後はきちんと把握して、バージョンアップの際は確認をするようにしたいと思います。

エラーの件ですが、ご提案のように.htaccess に「php_flag display_errors off」を追加し、PHP5.3を指定したところ、エラー・ログでは下記のエラーのみになりました。また、サイトにはこのエラーは表示されなくなりました。すべてのページをチェックしたわけではありませんが、表示には特に目立った不具合は見受けられないので、再構築までこのままでも問題ない気もしています。こまめにバックアップを取って、もし不具合が見つかったら対応を考えようと思います。
アドバイスありがとうございました。大変助かりました。

[08-Apr-2014 13:59:40 Asia/Tokyo] PHP Deprecated: Function eregi() is deprecated in /home/sites/heteml/users125/m/e/l/user/sitename/plugins/system/rokbox.php on line 98
最終編集: 5 年 7 ヶ月 ago : Eileen.
ゲストの書き込みは許可されていません。