Forum
J! JAPAN TOP
ようこそ, ゲスト
ユーザ名: パスワード: 自動ログイン

トピック: さくらインターネットレンタルサーバでSEO設定

さくらインターネットレンタルサーバでSEO設定 9 年 11 ヶ月 ago #2011

  • ビギナー
  • ビギナー さんのアバター
  • Offline
  • Fresh Boarder
  • 投稿数: 3
  • カルマ: 0
今月さくらインターネットのレンタルサーバースタンダードタイプでJoomla! 1.5.21 のコンテンツを立ち上げました。四苦八苦しながらWeb閲覧は出来るようになったのですが、Joomla-基本設定-SEO設定で、サーチエンジンフレンドリー、Apache mod_rewriteを利用、サフィックスをURLに追加を「はい」にすると、閲覧不可能となりエラーとなります。いろいろ見ているとたぶん、htaccess.txtを.htaccessにリネームする前後の処理だと思うのですが
何をしても閲覧不可能になります。なので、現状はhtaccess.txtのままで、SEO設定は全部「いいえ」にしてます。(この場合はインタネット閲覧可能)SEO設定をしたいのですが、何か良い解決方法ご存知ないでしょうか?
ゲストの書き込みは許可されていません。

Re:さくらインターネットレンタルサーバでSEO設定 9 年 11 ヶ月 ago #2014

  • Richell
  • Richell さんのアバター
  • Offline
  • Moderator
  • 投稿数: 65
  • 感謝を受け取りました 4
  • カルマ: 2
こんにちは。さくらで動かしているJoomla!を確認しましたが、
htaccessファイルの23行目の
Options +FollowSymLinks
の先頭に
# Options +FollowSymLinks
このように#を書いて保存してうまく動作しています。
そちらではいかがでしょうか。
ゲストの書き込みは許可されていません。

Re:さくらインターネットレンタルサーバでSEO設定 9 年 11 ヶ月 ago #2019

  • ビギナー
  • ビギナー さんのアバター
  • Offline
  • Fresh Boarder
  • 投稿数: 3
  • カルマ: 0
助言ありがとうございます。

さっそく、htaccess.txtの23行目に#を入れ、まずは基本設定の右画面のSEO設定-サーチエンジンフレンドリーURLを”はい”にしてサイトへアクセスしたところ、Topページは大丈夫なのですが、2階層以降は404エラー(添付参照)にて、表示がされません。

ちなみに、上記の状態でhtaccess.txtを.htaccessに変更してみたのですが、やはり2階層でhttp404エラーが出てきます。

もしその他の方法があればお願いします。
ゲストの書き込みは許可されていません。

Re:さくらインターネットレンタルサーバでSEO設定 9 年 11 ヶ月 ago #2020

  • siraisi
  • siraisi さんのアバター
  • Offline
  • Platinum Boarder
  • 投稿数: 462
  • 感謝を受け取りました 47
  • カルマ: 32
>何をしても閲覧不可能になります。

何をどのように設定したのか?わからないのですが。

.htaccess を下記のように変更してみてはいかがでしょう。

Options +FollowSymLinks

# Options +FollowSymLinks

# RewriteBase /
   ↓
RewriteBase /
mail: このメールアドレスはスパムボットから保護されています。閲覧するにはJavaScriptを有効にする必要があります。
ゲストの書き込みは許可されていません。