Forum
J! JAPAN TOP
ようこそ, ゲスト
ユーザ名: パスワード: 自動ログイン

トピック: joomlaの各4種(CENTOS Apache  MySQL PHP)最適バージョンの組み合わせ

joomlaの各4種(CENTOS Apache  MySQL PHP)最適バージョンの組み合わせ 3 年 3 ヶ月 ago #4883

  • wai
  • wai さんのアバター
  • Offline
  • Fresh Boarder
  • 投稿数: 10
  • カルマ: 0
joomla3.3.3japaneseの各4種(CENTOS Apache  MySQL PHP)最適バージョンの組み合わせを教えていただきたく。

「PHP 5.3.10以上の環境の 3.2 ユーザは 3.3 にアップグレードすることをおすすめします。」とありますが、逆にPHPバージョンの上限はあるのでしょうか。
(たとえば、PHP5.5.15は最新すぎるとか・・・)

「PHP 5.3.10以上の環境の 3.2 ユーザは 3.3 にアップグレードすることをおすすめします。」とありますが、ほかの CENTOS Apache  MySQL などの環境の
おすすめはどうなっているのでしょうか。
ゲストの書き込みは許可されていません。

joomlaの各4種(CENTOS Apache  MySQL PHP)最適バージョンの組み合わせ 3 年 3 ヶ月 ago #4885

  • siraisi
  • siraisi さんのアバター
  • Offline
  • Platinum Boarder
  • 投稿数: 457
  • 感謝を受け取りました 45
  • カルマ: 32
CentOS6でOK Apache2.x+ PHP5.4+ MySQL5.1+ が推奨環境みたいです。PHP5.5はJoomla! Extensions(サードパーティ製のコンポーネントやモジュール)の動作環境の兼ね合いもありますので、確認が必要となります。
今までの経験から最新バージョンを追わずに、一歩遅れた枯れかけたバージョンの方がよろしいかと思います。
extensions.joomla.org/

Joomla!の動作環境は下記にあります。
www.joomla.org/technical-requirements.html
mail: このメールアドレスはスパムボットから保護されています。閲覧するにはJavaScriptを有効にする必要があります。
ゲストの書き込みは許可されていません。
次のユーザが感謝しました: Richell

joomlaの各4種(CENTOS Apache  MySQL PHP)最適バージョンの組み合わせ 3 年 3 ヶ月 ago #4887

  • wai
  • wai さんのアバター
  • Offline
  • Fresh Boarder
  • 投稿数: 10
  • カルマ: 0
siraisiさん、いつもご返事ありがとうございます。
よくわかりました。

ちなみに、www.joomla.org/technical-requirements.html にはOS関連が掲載されてないみたいですが、動作環境としてのOS関連は何か情報掲示はされているのでしょうか。

個人的に悩んでいるのがCENTOSとDebianの選択です。(VPSで使用する場合)
※将来は商用としてJoomlaを活用していきたいです。

CENTOS・・・長所 CENTOS自体信頼性がありそう、また、将来的にはRHELとして商用としてサポートを受けられる道が開かれている
      短所 ある程度最新のPHP5.4などをインストールしようとすると外部リポジトリを自分で設定したり、依存性が違えばそれを
         自分で解消しなくてはならない面倒さがある。
        (VPSプリインストールの環境だけ(PHP3.3.3で我慢する)を使えば個人的な手間はかからない、という選択もあると思いますが)
Debian・・・長所 パッケージがしっかりしているので、自分で外部リポジトリを設定してインストールするなどの手間が省けるみたい。
      短所 商用としてサポートを受けられる道が無いので最後まで自分ががんばらなければならない。

将来は商用としてJoomlaを活用していくならやはりCENTOSかな。と思っている次第です。




        
ゲストの書き込みは許可されていません。

joomlaの各4種(CENTOS Apache  MySQL PHP)最適バージョンの組み合わせ 3 年 3 ヶ月 ago #4888

  • siraisi
  • siraisi さんのアバター
  • Offline
  • Platinum Boarder
  • 投稿数: 457
  • 感謝を受け取りました 45
  • カルマ: 32
Joomla!はWindows系、Linux系どちらのサーバーでも動作いたします。

私は、一時、コミュニティの空中分解の危機もありましたが、CentOSを使い続けています。Debianも今人気のようですね。

2年ぐらい前でしたか、ファーストサーバーでメンテナンス責任者が、誤って削除コマンド打ってしまい、データが消失するという事故がありました。
このような事故があると想定して、将来、Joomla!を商用で使うなら、レンタルサーバー会社の分散使用をお勧めします。
mail: このメールアドレスはスパムボットから保護されています。閲覧するにはJavaScriptを有効にする必要があります。
ゲストの書き込みは許可されていません。